HeyGov Dashboard not accessible
Resolved·Full outage

Issue with the hosting provider is resolved

Tue, Nov 18, 2025, 03:15 PM
(3 weeks ago)
·
Affected components
Dashboard
Updates

Resolved

Issue with the hosting provider is resolved

Tue, Nov 18, 2025, 03:15 PM

Monitoring

Issue resolved, we are monitoring the Dashboard

Tue, Nov 18, 2025, 03:12 PM

Identified

Identified as an issue with a 3rd-party service we use, Cloudflare, and we're working on a solution

Tue, Nov 18, 2025, 03:02 PM

Investigating

The Dashboard is not accessible for anyone, investigating.

Tue, Nov 18, 2025, 02:54 PM